Forum eedomus
https://forum.eedomus.com/

Sonos
https://forum.eedomus.com/viewtopic.php?f=59&t=5671
Page 1 sur 6  Suivant »
Auteur:  latoupie [ 05 Juil 2017 20:37 ]
Sujet du message:  Sonos

Pour ne pas polluer le post de la team, j'ouvre un nouveau sujet sur les enceintes Sonos qui sont maintenant intégrées dans l'eedomus.(j'ai fait un copier coller du post d Anne Marie sur la caméra netatmo ;) qui a eu une bonne initiative.
A vos posts constructifs pour les bonnes idées

Envoyé de mon ZX 81
Auteur:  donDams [ 08 Juil 2017 07:57 ]
Sujet du message:  Re: Sonos

Bonjour,

bon bin je me lance et je pose la première question. ;)
J'ai un capteur http qui me donne la météo du jour en format texte. Est-il possible de lire cet état avec ma sonos?

Capture.JPG
Capture.JPG (66.21 Kio) Consulté 9723 fois


Dans l'exemple sonos il y a une variable [TIME] qui me donne l'heure courante. d'où provient cette variable? t a t-il d'autre variables que je peux récupéré de la même façon (la date par exemple?)

Merci

Damien
Auteur:  latoupie [ 08 Juil 2017 17:23 ]
Sujet du message:  Re: Sonos

donc ça fonctionne chez toi les sonos ?
Je viens d'envoyer un ticket au support car ça ne fonctionne pas chez moi
Soyons patient :roll:
Auteur:  donDams [ 09 Juil 2017 08:18 ]
Sujet du message:  Re: Sonos

oui, ça marche, je commande la play 1(Play, Stop, Pause) et j'arrive à lire des textes.
Par contre j'ai pas tout compris pour le reste, lecture de deezer, lecture des variables...
Auteur:  latoupie [ 09 Juil 2017 08:28 ]
Sujet du message:  Re: Sonos

Tu as renseigné la case "Var1" ou non?

Envoyé de mon Nexus 10 en utilisant Tapatalk
Auteur:  donDams [ 09 Juil 2017 08:31 ]
Sujet du message:  Re: Sonos

Non, par exemple pour donner l'heure:
Capture.JPG
Capture.JPG (17.17 Kio) Consulté 9705 fois
Auteur:  latoupie [ 09 Juil 2017 09:09 ]
Sujet du message:  Re: Sonos

De toute façon, j'ai toujours le même message. Couldn't connect to host

Envoyé de mon ZX 81
Auteur:  yann69 [ 09 Juil 2017 22:33 ]
Sujet du message:  Re: Sonos

dans var1 il faut mettre le nom de ta zone et bien respecter le majuscule
Auteur:  Kernum [ 17 Juil 2017 15:30 ]
Sujet du message:  Re: Sonos

donDams a écrit:Bonjour,

bon bin je me lance et je pose la première question. ;)
J'ai un capteur http qui me donne la météo du jour en format texte. Est-il possible de lire cet état avec ma sonos?

Capture.JPG


Dans l'exemple sonos il y a une variable [TIME] qui me donne l'heure courante. d'où provient cette variable? t a t-il d'autre variables que je peux récupéré de la même façon (la date par exemple?)

Merci

Damien


Si tu veux lire une donnée d'un de tes capteur il suffit d'utiliser la variable [LAST_VALUE PERIPH_ID=API_du_capteur].
Pour récupérer l'API du capteur tu vas dans la configuration de ce capteur dans le mode Expert et c'est affiché.

J'ai trouvé des variables utilisables dans la configuration Eedomus.
Configuration -> Onglet "Programmation" -> Onglet "Règles" -> Nouvelle règle

Ensuite tu coche notification et tu va sur le petit "?" à "contenu de la notification".
Il y a surement plus simple je pense (enfin j'espère) mais moi je n'ai trouvé que ça ^^
Bon courage.
Auteur:  latoupie [ 19 Juil 2017 14:56 ]
Sujet du message:  Re: Sonos

latoupie a écrit:De toute façon, j'ai toujours le même message. Couldn't connect to host

Envoyé de mon ZX 81


Suite à un ticket, la team a en partie réglé mon problème: Sur 2 sonos, un fonctionne bien.
En revanche, impossible de commander le second même en ayant recréé un nouveau périphérique et renseigné correctement la partie "var" :cry:
J'attends une réponse :idea:
Auteur:  latoupie [ 19 Juil 2017 15:03 ]
Sujet du message:  Re: Sonos

Pour ceux chez qui le sonos fonctionne, auriez vous la gentillesse de me dire comment renseigner l'URL pour une playlist précise existante sur spotify ?
J'ai trouvé pour lancer une radio (pas trop compliqué) mais pas pour une playlist
Merci
Auteur:  dplein [ 19 Juil 2017 19:06 ]
Sujet du message:  Re: Sonos

Et dire que moi , je n'arrive même pas à faire lire un mp3 depuis mon nas...

Alors pareil, si une âme charitable passe par la....

Merci tout plein d'avance....
Auteur:  latoupie [ 21 Juil 2017 16:59 ]
Sujet du message:  Re: Sonos

latoupie a écrit:
latoupie a écrit:De toute façon, j'ai toujours le même message. Couldn't connect to host

Envoyé de mon ZX 81


Suite à un ticket, la team a en partie réglé mon problème: Sur 2 sonos, un fonctionne bien.
En revanche, impossible de commander le second même en ayant recréé un nouveau périphérique et renseigné correctement la partie "var" :cry:
J'attends une réponse :idea:


Bon , autant la team a été réactive lors de mon ticket, autant là, pour le deuxième sonos qui n'est pas reconnu, c'est calme plat !!!! :twisted:
Si la team passe par là, le numéro du ticket est le : #49420
Merci
Auteur:  Kernum [ 24 Juil 2017 10:31 ]
Sujet du message:  Re: Sonos

dplein a écrit:Et dire que moi , je n'arrive même pas à faire lire un mp3 depuis mon nas...

Alors pareil, si une âme charitable passe par la....

Merci tout plein d'avance....


Bonjour,
en fait pour l'instant il n'y a pas de commande qui lance directement une musique.
Tu est obligé de charger ta musique (et non la lire) qui doit être hébergée sur un serveur web (afin d'être accessible par une URL en http://).

Cela signifie que pour lire un MP3 hébergé sur ton Nas, il faudra passer par un actionneur UPNP qui aura au moins une valeur pour "charger ta musique" et une autre pour faire "Play". Il faudra ensuite passer par une règle pour lancer directement ta musique après l'avoir chargée.

Je ne sais pas si je suis clair ... si t'as des questions n'hésite pas.

Kernum
Auteur:  dplein [ 24 Juil 2017 18:15 ]
Sujet du message:  Re: Sonos

Merci Kernum,

Donc en fait, c'est mort...
Auteur:  Kernum [ 26 Juil 2017 10:33 ]
Sujet du message:  Re: Sonos

dplein a écrit:Merci Kernum,

Donc en fait, c'est mort...


Non c'est pas mort c'est juste que si tu veux une commande qui charge et lance en meme temps la musique, oui c'est mort :lol:
En revanche il devrait être possible de créer une règle qui te permette de faire tout ça. C'est plus lourd mais à mon avis faisable. SI ça t'interesse je peux me pencher sur la question et te sortir rapidement un tuto pour le mettre en place.
Auteur:  Kernum [ 26 Juil 2017 11:54 ]
Sujet du message:  Re: Sonos

Kernum a écrit:
dplein a écrit:Merci Kernum,

Donc en fait, c'est mort...


Non c'est pas mort c'est juste que si tu veux une commande qui charge et lance en meme temps la musique, oui c'est mort :lol:
En revanche il devrait être possible de créer une règle qui te permette de faire tout ça. C'est plus lourd mais à mon avis faisable. SI ça t'interesse je peux me pencher la question et te sortir rapidement un tuto pour le mettre en place.


Bon j'ai regardé 5 minutes voir si ce que je disais était faisable ... la réponse est oui :mrgreen:

Il suffit donc de passer par un actionneur UPNP et de créer une règle.

- Donc tu crées ton actionneur UPNP
- Tu mets l'adresse IP du Sonos sur lequel tu souhaites que ton MP3 soit joué. Tu "sauves et continues".
- Tu vas dans "valeur", et tu mets le lien http de ton MP3 à charger (hébergé normalement sur ton serveur web) dans la valeur "charger une piste". Normalement ce sera sous la forme &track=http://adresse_ip_serveur_web:port_serveur_web/ton_mp3.mp3
- Tu vas dans "Règles associées" et tu crées une nouvelle règle.
- Tu mets tes critères "ton_actionneur_UPNP" ->devient maintenant -> égal à -> charger piste là ou tu as mis la piste à charger) -> -(rien)
- Tu vas dans action et tu mets "ton_actionneur_UPNP" -> Play
- Tu sauves et c'est bon.

Maintenant que tu selectionnera "charger la piste" où se trouve ton MP3 l'action de lecture sera enchainée directement.

En tout cas chez moi ça fonctionne.
Si t'as des questions n'hésites pas ;)
Auteur:  dplein [ 27 Juil 2017 08:08 ]
Sujet du message:  Re: Sonos

Merci bien Kernum, je vais essayer tout ça !!!!!
Auteur:  Kernum [ 28 Juil 2017 10:07 ]
Sujet du message:  Re: Sonos

dplein a écrit:Merci bien Kernum, je vais essayer tout ça !!!!!


Ok tiens moi au courant.
Auteur:  dplein [ 28 Juil 2017 11:52 ]
Sujet du message:  Re: Sonos

Alors alors, j'ai commencé les premiers essais hier soir qui ne sont pas concluants.

En fait, aucun son ne sort de la play1. Le fichier y est bien chargé...mais que dalle... et lorsque je clique sur le bouton play de l'appli sonos, cela me marque "impossible de lire le fichier *.mp3. Le fichier est introuvable.

Par contre, je n'ai pas mis de port après ip de mon nas.
Page 1 sur 6 Le fuseau horaire est UTC+1 heure