[Store] Gestion des cartes-relais chinoises

Discussion et échanges de scripts pour la box eedomus

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 28 Mars 2019 17:29

Essam10 a écrit:tu as essayé des sondes de Temp en entrée?

Salut,

Pas de raison que ça fonctionne, les entrées sont des contacts secs ;)

Jacky a écrit:Bonjour rover820i !
Merci pour ton script qui 'm'a conduit à acheter le net relais.
Je viens de l'installer sur mon réseau, et sur eedomus mais aucune règle n'est créee.
Et les commandes sur les sorties n'actionnent pas les relais ...
Que dois-je faire ?

merci !

Jacky
Salut,

Tu as commandé le modèle que j'ai mis dans mon 1er message ?

Curieux qu'aucune règle ne soit créée ; j'ai bien revérifié mon script et tout se crée bien.

As-tu bien une eedomus+ ?

Les entrées répondent bien quand elles s'activent et se désactivent ?

Pour les commandes de sortie, fais un test manuel en appelant directement l'adresse :

http://login:modepasse@iprelais/relay.cgi?relayon1=on
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Essam10 » 29 Mars 2019 08:18

Pas de soucis pour ton script il fonctionne nickel!
Eedomus +
RFXcom (5 Volets Simu , 3 Chacon Dio, Pluviomètre PCR800,6TGHN132N, 1THGR122NX)
Zigate (7 xiaomi ouverture porte)
Capteur Garage Vision Zwave
2 Sonoff Basic
Essam10
 
Messages : 124
Inscription : 12 Jan 2018
Localisation : Leuze - Belgique

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 29 Mars 2019 11:16

Merci de ta réponse,

Oui j'ai commandé le même modèle.
La ou les règles se créent dans quel périphérique ?
Oui j'ai une eedomus+
Oui par le navigateur, les sorties répondent bien lorsque je les active ou désactive
Par contre ton lien n'actionne pas la sortie et me renvoie vers la page d'accueil de la carte relais
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 29 Mars 2019 11:52

Les règles ne se créent pas dans un périphérique mais dans la liste des règles ;)

Depuis la page de la carte relais, appuie sur la touche F12 de ton navigateur, va sur l'onglet Network (chrome et firefox), et ouvre ou ferme un des relais, et dis-moi quelle adresse s'affiche dans l'onglet network.
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 29 Mars 2019 16:07

rover820i a écrit:Les règles ne se créent pas dans un périphérique mais dans la liste des règles ;)

Depuis la page de la carte relais, appuie sur la touche F12 de ton navigateur, va sur l'onglet Network (chrome et firefox), et ouvre ou ferme un des relais, et dis-moi quelle adresse s'affiche dans l'onglet network.


Oui pour les règles mais elles concernent en général un périphérique ;-)
En tout cas dans la liste des règles rien de nouveau de crée.

Je suis sur mac donc F12 n'est pas active ni sur Firefox ni sur Chrome.
mais dans console lors de l'activation d'un relais s'affiche :
[Exception... "Favicon at "http://192.168.23.201/favicon.ico" failed to load: Not Found." nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 199" data: no]

Est-ce ce que tu voulais ?
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 29 Mars 2019 16:16

Non, j'ai besoin de récupérer l'URL qui est appelée lors de l'ouverture ou la fermeture d'un relais.
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 29 Mars 2019 16:36

URL de la requête :http://192.168.23.201/relay_en.cgi
Méthode de la requête :POST
Adresse distante :192.168.23.201:80
Code d’état :
200
Version :HTTP/1.1
Politique de référent :strict-origin-when-cross-origin


Cela te convient-il ?
l'url est la même quelque soit le relais activé ou désactivé

Veux-tu le code source de la page ?
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 29 Mars 2019 17:05

Le firmware n'est pas identique à ma carte donc ça ne peut pas fonctionner.

Essaie de remplacer, dans les périphériques "xxx sorties relais xx", au niveau des valeurs, relay.cgi par relay_en.cgi
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 29 Mars 2019 19:56

fait ! mais ça n'active pas la sortie
comme s'il manquait l'argument correspondant à ON ou OFF (ou comme s'il n'était pas bon )

Le type de la requête dans les valeurs est GET. C'est normal ?
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 30 Mars 2019 10:33

Essaie de passer les arguments en post, et de remplacer les arguments actuels par saida1off=off pour éteindre et saida1on=on pour allumer, sur le relais 1
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 30 Mars 2019 11:44

fait ! mais toujours pas d'action
Jacky
 
Messages : 26
Inscription : 19 Juin 2016


Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 30 Mars 2019 12:05

Non désolé, aucun des trois ne déclenche la sortie.
Les deux premiers liens me renvoient juste vers la page d'accueil en anglais, le troisième vers la page en chinois
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 30 Mars 2019 15:36

Demande au vendeur de t'envoyer la doc spécifique à ton modèle et transmets le moi. Tu as peut-être commandé une autre variante.
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 30 Mars 2019 22:41

je te l'ai transmise en MP
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 02 Avr 2019 08:40

Salut,

Après vérification, c'est parce que tu as commandé la version V6C qui n'est pas compatible avec les requêtes HTTP.

C'est corrigeable pour fonctionner via TCP mais ça va demander de l'adaptation pour le script.

Afin de ne pas risquer de pannes sur les installations existantes, je vais faire une appli à part, je te l'enverrai pour que tu testes l'installation complète. Donne moi ton mail en MP

EDIT => script prêt. Envoie ton mail pour que tu puisses faire un test d'installation. Tu sais comment soumettre un script sur le store ?
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Dmp » 24 Avr 2019 06:52

Bonjour, suite à ce post, j'ai décidé d'acheter le modul
net-relay sur Aliexpress que j'ai reçus hier. Cependant, je rencontre le même problème que Jacky. Le script de rover820i ne fonctionne pas chez moi. Lorsque je saisis directement la requette http cela m'affiche la page web d'administration des sorties du modul mais elles ne sont pas activées. J'ai testé toutes les requettes des precedents echanges sans succès.
Je suis pourtant pratiquement sûre d'avoir commender la version v6 et pas la v6c.
Pourriez vous m'aider à identifier comment piloter ce modul avec ma eedomus? Sans doute en post/get via module virtuel...
Dmp
 
Messages : 2
Inscription : 24 Avr 2019

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Jacky » 24 Avr 2019 08:08

Bonjour,
Pour info, je n'ai toujours pas de solution pour piloter ce module avec eedomus.
Rover va essayer de régler ça mais il est très absorbé par son travail pour l'instant.
Jacky
 
Messages : 26
Inscription : 19 Juin 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar rover820i » 24 Avr 2019 14:22

Jacky, je viens de t'envoyer un script pour tester un truc
rover820i
 
Messages : 2953
Inscription : 23 Juil 2016

Re: [Store] Gestion des cartes-relais chinoises

Messagepar Dmp » 24 Avr 2019 16:42

Merci pour l'info. Je suis prêt à tester aussi si besoin ;)
Dmp
 
Messages : 2
Inscription : 24 Avr 2019

PrécédentSuivant

Retour vers Scripts & Périphériques du store

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invité(s)