Solution pour un vrai émetteur/récepteur Z-Wave 5-15Vdc

Tout ce qui concerne l'usage des périphériques radios Z-Wave avec eedomus

Solution pour un vrai émetteur/récepteur Z-Wave 5-15Vdc

Messagepar steph » 18 Mars 2013 14:42

Bonjour,

Depuis quelque temps je cherchais une solution pour piloter en Zwave mon portail 100% solaire.
La problématique : Impossible de trouver un émetteur/récepteur Zwave qui s'alimente entre 14Vdc et 10Vdc (tension batterie en charge puis déchargé + marge).
La solution, je l’ai trouvé en démontant un module Fibaro FGS221.
La première étape consiste à changer les relais 12Vdc par des 6 Vdc ex TE CONNECTIVITY / SCHRACK - 1393217-2 dispo chez Farnell pour 6.45€ HT unitaire (2060757)

Relais_1-1.jpg
Changement de relais
Relais_1-1.jpg (26.56 Kio) Consulté 1086 fois


Cependant, cela n’est pas suffisant, ce module n’étant pas prévu pour être alimenté aussi bas en tension, il faut s’attaquer à l’alimentation, rien de plus simple car Fibaro utilise un LNK302 qui est une alimentation à découpage input 85Vac 265Vac est fourni une tension de sortie de 12Vdc. Il nous faut donc bypasser ce circuit et attaquer directement le regulateur lineaire 3.3Vdc.

Schéma de la doc du LNK :
LNK302.jpg
LNK302
LNK302.jpg (53.25 Kio) Consulté 1086 fois


Il nous faut donc supprimer RF1, D2 et L1 afin d’isoler complètement l’alim à découpage et ramener l'alimentation du bornier L directement à l'entrée du regulateur lineaire qui fourni le 3.3Vdc de la carte Zwave.

Modif-1.jpg
Modif
Modif-1.jpg (26.78 Kio) Consulté 1086 fois


Désolais, j'étais tellement pressé de tester la solution que je n’ai pas pris de photo une fois la carte strappé et les composants dessoudés. Mais si ça intéresse du monde, je peux le redémonter pour prendre des photo.

Les tests :
- fonctionne à partir de 5Vdc (L = +5Vdc et N=0Vdc) je conseigne tout de meme 6Vdc (4 pile 1.5V ;) )
- Je l’ai testé jusqu’à 15Vdc, pas un poil d’échauffement du régulateur linéaire 3.3V. Oui il ne faut pas oublier que vous attaquez directement le régulateur linéaire et comme aucune ref n’est placé dessus, je suis incapable de vous fournir ces caractéristiques, cependant étant donné qu’il est initialement alimenté en 12Vdc, je présume sur au moins 18Vdc.
- en test chez moi depuis quelque jour sur mon portail, pas de problème.

Attention, le module n'est plus sous garantie apres ces modif
Attention, ne plus alimenter le module en 230Vac, logique, mais je prefere le preciser...

Et voilà, si vous faites ces modifs vous pouvez connaitre l’état d’un équipement alimenté de 5Vdc à 15Vdc mais aussi et surtout vous pourrez également le piloter (ex domotiser des équipements qui fonctionne sur pile…)

Steph
steph
 
Messages : 38
Inscription : 02 Mars 2013

Retour vers Périphériques Z-Wave

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)