Utilisation du Tag Last Value

Capteurs et actionneurs HTTP

Utilisation du Tag Last Value

Messagepar cedriclocqueneux » 30 Oct 2012 14:25

J'ai travaillé ce matin avec les nouveaux tags, dans les notifications par mail pas de soucis, mais dans les actionneurs HTTP ca ne semble pas fonctionner.

J'ai un actionneur HTTP configuré ainsi:

http://www.michamps4b.be/importdata.php

?frombox=eedomus&LOGIN=monlogin&PWD=motdepasse&CEN=[LAST_VALUE PERIPH_ID=8900]

Pour envoyer une valeur à un site distant. Mais le tag n'est pas remplacé, la personne qui tient le site distant m'a bien confirmé voir cette URL arriver inchangée, avec les crochets.

Sinon, vous me confirmez qu'il est possible d'envoyer plusieurs tags différents (même tag, mais avec un ID différent) dans une même requête / notification ?

Et peut on l'utiliser dans les valeurs configurées sur un Karotz ? Je n'ai pas l'impression que ca fonctionne.
Image
cedriclocqueneux
 
Messages : 159
Inscription : 10 Jan 2012
Localisation : Orléans, France

Re: Utilisation du Tag Last Value

Messagepar support_eedomus » 30 Oct 2012 16:10

Bonjour,

cedriclocqueneux a écrit:Pour envoyer une valeur à un site distant. Mais le tag n'est pas remplacé, la personne qui tient le site distant m'a bien confirmé voir cette URL arriver inchangée, avec les crochets.

Cela devrait effectivement fonctionner. Nous voyons avec vous par mail afin de comprendre s'il s'agit d'un bug ou d'une erreur de syntaxe.
cedriclocqueneux a écrit:Sinon, vous me confirmez qu'il est possible d'envoyer plusieurs tags différents (même tag, mais avec un ID différent) dans une même requête / notification ?

Ce n'était pas possible jusqu'à ce jour, un patch a été publié cet après-midi pour améliorer cela, un même type de tag peut désormais être utilisé plusieurs fois

cedriclocqueneux a écrit:Et peut on l'utiliser dans les valeurs configurées sur un Karotz ? Je n'ai pas l'impression que ca fonctionne.

Vous avez raison, nous avons donc activé cela dans la version de cet après-midi, n'hésitez pas à nous signaler si cela ne fonctionnait pas.
Image L'équipe eedomus
http://www.eedomus.com
support_eedomus
 
Messages : 561
Inscription : 09 Jan 2012
Localisation : France

Re: Utilisation du Tag Last Value

Messagepar cedriclocqueneux » 30 Oct 2012 16:38

Merci, la requête semble fonctionner correctement, maintenant !

Je teste mon Karotz ce soir. Merci pour ces petites améliorations rapides !
Image
cedriclocqueneux
 
Messages : 159
Inscription : 10 Jan 2012
Localisation : Orléans, France

Re: Utilisation du Tag Last Value

Messagepar Chacks » 30 Oct 2012 18:56

Pour moi ça fonctionne bien sur le karotz.

@+
1 EEDOMUS, modules FIBARO, IPX800 V3, Arduino, sondes T & Rh WS1170
Chacks
 
Messages : 227
Inscription : 06 Mars 2012

Re: Utilisation du Tag Last Value

Messagepar Chacks » 30 Oct 2012 20:27

Par contre j'ai juste une petite remarque concernant l'utilisation du tag Last Value

J'ai paramétrer mon périphérique Karotz pour qu'il puisse me donner la température d'un capteur (mon frigo) en utilisant le tag Last_Value.

Dans la liste de choix j'ai donc une ligne de cette forme : La température du frigo est de [LAST_VALUE PERIPH_ID=xxxx] degré

Quand je sélectionne cette commande, ça m'affiche la phrase ci-dessus alors que j'aurais préféré que ça m'affiche la phrase en remplaçant le tag par la valeur réelle (Par contre dans la liste de choix, ça doit rester avec le tag bien sur)

J'espère avoir été clair.

Merci pour cette super mise à jour.

@+
1 EEDOMUS, modules FIBARO, IPX800 V3, Arduino, sondes T & Rh WS1170
Chacks
 
Messages : 227
Inscription : 06 Mars 2012

Re: Utilisation du Tag Last Value

Messagepar Kermichon » 30 Oct 2012 21:42

Très bien le principe de ce Tag, mais je ne parviens pas à l'utiliser avec le nouveau périphérique Conversion Consommation Euros :
Je voudrais que le lapin me donne ma production d'électricité de la journée mais ça me renvoie zéro.

En fait, le périphérique Conversion Consommation Euros affiche un histogramme et me donne bien ma production de la journée mais il est probable que la dernière valeur interne soit zéro, lorsque le soleil se couche.

Donc, je vois bien ma bonne production de courant mais la dernière valeur renvoyée est zéro...

Comprenez vous mon problème ? Que puis-je faire pour récupérer et diffuser à mon lapin la valeur produite de la journée ?
Merci pour votre aide.
Kermichon
 
Messages : 158
Inscription : 29 Avr 2012

Re: Utilisation du Tag Last Value

Messagepar rom61 » 03 Nov 2012 12:16

Je sais pas si j'ai bien compris l'utilité du tag last value mais je souhaite
récuperer la valeur d'un capteur de temperature zwave
dans un capteur http pour le soustraire.

Ce capteur de température a un décalage de 3 °C donc en récupèrent cette valeur avec
une soustraction de -3 j'aurais la bonne température

Cela est'il possible ?
rom61
 
Messages : 97
Inscription : 17 Mars 2012
Localisation : 61

Re: Utilisation du Tag Last Value

Messagepar MicroFire » 10 Nov 2012 05:40

rom61 a écrit:Je sais pas si j'ai bien compris l'utilité du tag last value mais je souhaite
récuperer la valeur d'un capteur de temperature zwave
dans un capteur http pour le soustraire.

Ce capteur de température a un décalage de 3 °C donc en récupèrent cette valeur avec
une soustraction de -3 j'aurais la bonne température

Cela est'il possible ?

Bonne insomnie à tous et à toutes,

Je recherche à faire la même chose mais en divisant par 10, j'ai essayé avec cette commande "[LAST_VALUE PERIPH_ID=9027] div 10" mais sans succès :(

Y a t'il un moyen de diviser la valeur par 10 ?

Merci d'avance.

Julien
Serveur Domotique Z-Wave: eedomus, ImperiHome V2 Beta
Modules: 4 Fibaro + 4 Everspring + 3 Düwi + 2 Aeon Labs + 1 Téléinfo USB
WikiBlog: http://www.WebDeveloppement.com
@ +
MicroFire
MicroFire
 
Messages : 116
Inscription : 10 Jan 2012


Retour vers Requêtes HTTP

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)