Problème d'arret sirène

Discussion sur la box eedomus

Problème d'arret sirène

Messagepar imhotep » 28 Oct 2013 16:32

Bonjour un tous, j'ai besoin de votre aide car je constate que mon alarme ne fonctionne pas comme je le voudrais.

Mon alarme est composée de:

- plusieurs capteur de mouvements multisensor,
- plusieurs capteur d'ouverture,
- 2 deux sirènes
- un miror (pour le "badgeage")
- un état nommé "Alarme anti-intrusion"

Le déclenchement de l'alarme (immédiat ou différé) par mouvement ou ouverture fonctionne nickel; mon problème est au niveau du désarment de l'alarme avant sont déclenchement différé.

Ce que je veux, c'est laisser 20 secondes pour désactiver l'alarme lorsque j'ouvre la porte d'entré.

voici la règle (et les deux macro associé) qui déclenche l'alarme:

declenchement_alarme_porte_entree.png
declenchement_alarme_porte_entree.png (77.19 Kio) Consulté 1505 fois


Et enfin celle qui est censé désactivé l'alarme:

desarmement_alarme.png
desarmement_alarme.png (58.31 Kio) Consulté 1505 fois


elle est assez simple au final: si l'état "Alarme anti-intrusion" est différent de "désarmé" et qu'un badge est passé sur le miror, on met les sirène sur "off", on passe l'état "Alarme anti-intrusion" sur "désarmé" et on notifie l'utilisateur via le Karotz et le clignotement du flash de la sirène pendant 10 secondes.

Lorsque que je rentre chez moi et que je passe mon badge sur le karotz, le flash clignote, le karotz dit "Alarme désactivée" mais les sirènes gueulent quand même au bout de 20 secondes :-(

Après avoir revus mes règles en long et en large et en travers, je me dis que les macros "20 secondes" des sirènes sont lancée au moment ou j'ouvre la porte d'entrée et que le passage des sirène a off interrompt pas les macro !

Alors que faire ? je suis ouvert à toutes idées et conseils.

PS: je n'ai volontairement pas utilisé la programmation native de la eedomus, car mes détecteurs de mouvements enclenchaient l’alarme à chaque fausse détection (c'est a dire souvent), j'ai donc créé des règles pour que l'alarme soit déclenché par des couple de capteur et non 1 seul.
imhotep
 
Messages : 15
Inscription : 12 Août 2013

Re: Problème d'arret sirène

Messagepar Nico33 » 28 Oct 2013 18:19

Peut-être simplement en mettant arrêt macro dans les choix de la macro ?
Nico33
 
Messages : 1013
Inscription : 14 Juin 2013

Re: Problème d'arret sirène

Messagepar DomoTiti62 » 28 Oct 2013 19:13

Bonjour,

Je pense que Nico33 à mis le doigt dessus. Dans ta règle de désarmement, tu devrais stopper tes macros dans la partie "Action".

Cordialement
DomoTiti62
 
Messages : 135
Inscription : 10 Oct 2012

Re: Problème d'arret sirène

Messagepar imhotep » 29 Oct 2013 10:34

Exact merci Nico c'est bien ça, j'ai remplacé "sirene => off" par "sirène => Macro [Arreter]" et ça fonctionne impec :-)

desarmement_alarme.png
desarmement_alarme.png (47.87 Kio) Consulté 1460 fois


Par contre j'ai découvert une limitation de la eedomus: on ne peux lancer qu'une macro par device dans une règle, du coup comme j'ai ajouté la macro "arrêter", j'ai du supprimer la macro qui faisait flasher ma sirène 10 seconde (pour notifier du désarmement).

Merci encore pour le coup de main.

a+
imhotep
 
Messages : 15
Inscription : 12 Août 2013


Retour vers Box eedomus

Qui est en ligne ?

Utilisateurs parcourant ce forum : Google [Bot] et 2 invité(s)