Forum eedomus
http://forum.eedomus.com/

Certificat HTTPS invalide
http://forum.eedomus.com/viewtopic.php?f=23&t=5832
Page 1 sur 1
Auteur:  AdrianPal [ 04 Sep 2017 21:47 ]
Sujet du message:  Certificat HTTPS invalide

Bonjour,

Je travaille actuellement sur une interface permettant une visualisation en live de tous mes périphériques. Cette dernière est en HTTPS, et doit donc communiquer vers des sites uniquement en HTTPS.

Cependant, quand je requête ma box eedomus en local, le certificat HTTPS est invalide et je ne peux donc rien en tirer (voir l'image). Est-il alors possible de modifier ce certificat pour qu'il soit valide ?

Image

Merci d'avance de vos réponses ! :)
Auteur:  rover820i [ 05 Sep 2017 09:45 ]
Sujet du message:  Re: Certificat HTTPS invalide

Salut,

Essaie à partir du point 4 (si tu as bien autosigné ton certificat) :

https://www.oboqo.com/blog/virtualhost- ... e-postman/
Auteur:  AdrianPal [ 06 Sep 2017 10:44 ]
Sujet du message:  Re: Certificat HTTPS invalide

Le problème, c'est que je souhaite porter cette application Web sur iOS, donc c'est pour cela qu'il faut un certificat valide de base... :?
Auteur:  rover820i [ 06 Sep 2017 15:06 ]
Sujet du message:  Re: Certificat HTTPS invalide

AdrianPal a écrit:Le problème, c'est que je souhaite porter cette application Web sur iOS, donc c'est pour cela qu'il faut un certificat valide de base... :?

Si tu comptes héberger en local avec accès internet, ça ne seras pas possible sur une adresse IP locale. Tu devras forcément le faire sur une IP internet (celle de ta box) et configurer ton serveur web local en conséquence. C'est toujours un peu la merde de configurer un certificat SSL.

Si tu comptes héberger ton appli sur un serveur web indépendant de ta connexion, alors ça sera plus simple. Chez 1&1 ils font ça de manière totalement transparente et ça ne coûte pas très cher.

Si tu veux la 1ère solution et qu'en plus, tu ne veux pas payer de certificat, tu pourras le prendre chez letsencrypt.org.
Page 1 sur 1 Le fuseau horaire est UTC+1 heure